Statistiques

La fonction =NB.SI()

Cette formule permet de compter le nombre de cellules non vides correspondant au critère désiré.

Voici sa syntaxe : =NB.SI(Plage;Critère)

  • Plage est la plage de cellules sur laquelle on va chercher le nombre de cellules correspondant au critère désiré,
  • Critère désigne le choix retenu, nombre ou texte.

Exemple : Dans le tableau ci-contre on désire compter le nombre de réponses “oui”. En D4 on écrit la formule suivante :

=NB.SI(B1:B7;“oui”)              Le résultat donne : 4

La fonction =NB.VAL()

Cette fonction compte le nombre de cellules non vides à l’intérieur d’une plage de cellules spécifiée. On peut l’utiliser, par exemple, pour connaître le nombre de personnes contenues dans une liste.

Voici sa syntaxe : =NBVAL(plage_de_cellules)

plage_de_cellules peut concerner plusieurs cellules contiguës ou dispersées.

Exemple : Dans le tableau ci-contre on cherche le nombre de noms (en fait le nombre de cellules non vides) figurant dans la liste. En B1 on écrit la formule suivante (volontairement on prendra une plage plus grande que celle contenant les noms) : =NBVAL(A1:A10) 

La fonction =NB.SI.ENS()

Cette formule permet d’additionner plusieurs cellules en fonction de plusieurs critères.

Voici sa syntaxe :

=NB.SI.ENS(Plage_critères1;Critères1;[plage_critères2;critères2];….))

Cette formule permet d’additionner plusieurs cellules en fonction de plusieurs critères.

Voici sa syntaxe :

=NB.SI.ENS(Plage_critères1;Critères1;plage_critères2;critères2;….))

Exemple, Ici :

  • Première Plage de critères ; la colonne du service, la colonne C (dans la formule C:C),
  • Premier critère, le service saisi en cellule G1,
  • Deuxième plage de critères, la colonne du sexe, la colonne B (dans la formule B:B),
  • Deuxième critère, le sexe saisie en cellule F2, 
La formule est la suivante  : NB.SI.ENS(E1:E22;H1;F1:F22;H2)

La fonction =NB.VIDE()

Cette fonction compte le nombre de cellules vides à l’intérieur d’une plage de cellules spécifiée. On peut l’utiliser, par exemple, pour connaître le nombre de cellules laissées vides dans une liste.

Voici sa syntaxe : =NBVAL(plage_de_cellules)

plage_de_cellules peut concerner plusieurs cellules contiguës ou dispersées.