Formules mathématiques

La fonction =SOMME()

Pour additionner entre elles plusieurs cellules contiguës, on peut utiliser la fonction SOMME d’EXCEL.

  • Ecrire dans la cellule où doit apparaître le résultat : =somme(Sélectionner ensuite à la souris la plage de cellules à additionner.

  • Valider avec la touche Entrée

  • La fonction renvoie l’addition des sommes sélectionnées.

Exemple : En A5 on écrit la formule suivante : =SOMME(A1:A4) Le résultat donne : 31

La fonction =SOMME.SI()

Cette fonction vous permet d’additionner plusieurs cellules en fonction d’un critère déterminé.

Voici sa syntaxe : =SOMME.SI(plage;critère;somme_plage)

  • plage est la plage de cellule contenant le critère à retenir
  • critère est LE critère à retenir (chiffre ou texte)
  • somme_plage est la plage de cellule où se trouvent les nombres à additionner.

Exemple : Dans la colonne A on a écrit des nombres. En colonne B, on a indiqué “garçon” ou “fille”. On voudrait obtenir le total des nombres de la colonne A auxquels correspondent le mot “fille” en colonne B.

CEn A7 on écrit la formule suivante : =SOMME.SI(B1:B6;“fille”;A1:A6)      Le résultat donne : 66

La fonction =SOMME.SI.ENS()

Cette formule permet d’additionner 9critères.

Voici sa syntaxe :

=SOMME.SI.ENS(plage_somme;Plage_critères1;Critères1;[plage_critères2;critères2];….))

La fonction =SOMMEPROD()

Réalisation d’opérations conditionnelles comptant et additionnant en utilisant des conditions multiples.

Les formules permettant de calculer le nombre de valeurs ou les sommes sont fondées sur deux conditions ou plus.

 La fonction que nous allons utiliser est =SOMMEPROD() ; celle-ci appartient à la catégorie Math & Trigo.

Exemple : Compter le nombre de mois où un commercial fait une vente. Le tableau de départ pourrait se présenter sous cette forme :

Exemple 1 : Compter le nombre des ventes faites par Jules sur le mois de février.

C’est une formule conditionnelle qui emploie deux conditions.

=SOMMEPROD((A2:A13=”Jules”)*(B2:B13=”Février”))   –   Résultat de formule: 2

Exemple 2 : Compter les mois où les ventes sont plus grandes qu’une quantité spécifique

Vous pouvez employer une formule semblable à celle ci-dessus pour travailler avec des données numériques. Cette formule renvoie le nombre de lignes pour lesquelles le mois est égal à janvier et le montant est supérieur à 200.

=SOMMEPROD((B2:B13=”Janvier”)*(C2:C13>200))      –     Résultat de formule: 5

La fonction =MOYENNE()

La fonction =ARRONDI()

Le résultat d’une division ou d’une multiplication peut donner un nombre comportant plusieurs décimales. Dans le but de créer des formulaires destinés à des tiers (exemple facture) les nombres doivent, en principe, se présenter avec simplement deux décimales. On peut, bien entendu, utiliser le format des nombres.

Mais Excel va conserver en mémoire le nombre initial avec plusieurs décimales et l’utilisera pour les calculs ultérieurs. D’où des problèmes d’affichages.

 Voici sa syntaxe :

=ARRONDI(nombre;No_chiffres)

Cette formule requiert deux arguments :

  • nombre est le nombre à arrondir. Ce nombre peut également être remplacé par la référence à une cellule contenant un nombre. Il peut également être une formule de calcul complexe.
  • No_chiffres représente le nombre de décimales que l’on souhaite obtenir.

Voici un exemple des arrondis possibles du nombre 10734,12 :

 

  • ARRONDI(10734,12;2)    donne   10734.12
  • ARRONDI(10734,12;1)    donne   10734.1
  • ARRONDI(10734,12;0)    donne   10734
  • ARRONDI(10734,12;-1)    donne  10730
  • ARRONDI(10734,12;-1,5)  donne  10735
  • ARRONDI(10734,12;-2)    donne   10700
  • ARRONDI(10734,12;-3)    donne   11000
  • ETC.

 

On aura donc par exemple pour obtenir le résultat du calcul 2/3 arrondi à 2 décimales :

 =ARRONDI(2/3;2)

Le résultat de cette formule sera 0.67. Ce nombre s’affichera directement dans la cellule sans que l’on ait besoin de passer par le format des nombres.

L’argument “nombre de décimales ” donne des arrondis différents selon le chiffre utilisé

La fonction =ARRONDI.INF()

=ARRONDI.INF(3,2;0) : Arrondit 3,2 à la valeur entière immédiatement inférieure (3)

=ARRONDI.INF(76,9;0) : Arrondit 76,9 à la valeur entière immédiatement inférieure (76)

=ARRONDI.INF(3,14159;3) : Arrondit 3,14159 à la valeur inférieure comportant trois décimales (3,141)

=ARRONDI.INF(-3,14159;1) : Arrondit -3,14159 à la valeur inférieure comportant une décimale (-3,1)

=ARRONDI.INF(31415,92654;-2) : Arrondit 31415,92654 à gauche du séparateur décimal, à la centaine immédiatement inférieure (31400)

La fonction =ARRONDI.SUP()

=ARRONDI.SUP(3,2;0) : Arrondit 3,2 à la valeur entière immédiatement supérieure (4)

=ARRONDI.SUP(76,9;0) : Arrondit 76,9 à la valeur entière immédiatement supérieure (77)

=ARRONDI.SUP(3,14159;3) : Arrondit 3,14159 à la valeur supérieure comportant trois décimales (3,142)

=ARRONDI.SUP(-3,14159;1) : Arrondit -3,14159 à la valeur supérieure comportant une décimale (-3,2)

=ARRONDI.SUP(31415,92654;-2) : Arrondit 31415,92654 à gauche du séparateur décimal, à la centaine immédiatement supérieure (31500)

La fonction =MAX()

La fonction =MIN()

La fonction =GRANDE.VALEUR()

La fonction =PETITE.VALEUR()