Fonctions logiques

La fonction =SI()

 

La formule compare tout d’abord le résultat obtenu en D5 au nombre 1000.

  • Si le montant en D5 est plus petit que 1000, alors (symbolisé par le point virgule) le résultat sera celui du calcul : 
    D5 multiplié par 5%.
  • Sinon (symbolisé par le deuxième point virgule) c’est à dire si le montant en D5 est égal ou plus grand que le nombre 1000, le résultat  sera celui du calcul :
    D5 multiplié par 10 %

La fonction =ET()

Exemple : On désire attribuer une ristourne de fin d’année de 2% aux clients qui remplissent les 2 conditions suivantes : être grossiste ET avoir acheté plus de 100 000 € de marchandises chez nous. Nos clients sont répertoriés dans le tableau ci-après :

La fonction =OU()

Si les conditions posées dans le test de la fonction =SI() sont multiples Il faut combiner cette formule avec la formule =OU(). Pour que la réponse aux conditions soit “VRAI“, il faudra que l’une au moins se vérifie.

=SI(OU(Cond1;Cond2;…;CondN);action à réaliser si au moins une des conditions est satisfaite;action à réaliser si aucune des conditions n’est satisfaite)

Exemple : Une entreprise souhaite verser une prime de fin d’année à ses représentants s’ils remplissent l’une OU l’autre des conditions suivantes :

  • Avoir plus de 5 ans d’ancienneté
  •  Avoir réalisé plus d’ 1 Million d’euros de chiffre d’affaires.

 Les représentants sont répertoriés dans le tableau suivant :

La fonction =SI.CONDITIONS()

Cette nouvelle fonction permet de poser plusieurs questions et de les associer avec une réponse « valeur si vrai ». Dès qu’Excel rencontre une réponse « Vrai », il affiche le résultat.

Exemple. On souhaite verser une commission en fonction d’un certain montant de chiffre d’affaires. 10% si le chiffre d’affaires dépasse 20 000 €, 8% s’il dépasse 15 000 €, 5% s’il dépasse 10 000 € et O en deçà de 10 000 €.

Attention, sachant qu’Excel s’arrête à la première réponse « Vrai » il faut faire attention à l’ordre des questions ! Ici on ne commencera pas la formule en demandant si le chiffre d’affaires est supérieur à 0 (zéro) car sinon il affichera O% de commission.

En supposant que le chiffre d’affaires soit saisi en cellule B2, Voici la formule :

=SI.CONDITIONS(B2>20000;10%;B2>15000;8%;B2>10000;5%;B2>0;0%)*B2

On termine en multipliant le pourcentage obtenu par le chiffre d’affaires (B2)