Dates et heures

Afficher des heures négatives avec le signe "-"

sIl faut créer et utiliser le format de nombre personnalisé suivant : [Rouge]-[h]:mm

Additionner des heures au delà de 24 heures

Essayez d’addidtionner : 15:30 et 20:50 , vous obtiendrez : 12:20 !

Comment dès lors pouvoir additionner des nombres saisis au format heures-minutes ?

Il suffit en fait d’appliquer un format de nombre personnalisé à la cellule contenant la formule de somme . Le format est le suivant (format à créer dans l’outil “Nombre” du Ruban “Accueil”. Choisir la catégorie “personnalisée” et écrire dans la zone “Type”)

C Multiplier des heures par des €uros

Pour obtenir un résultat en multipliant des heures par des Euros vous devez tout d’abord saisir les heures au format Excel, c’est à dire sous la forme :HH:MM.

Soit pour 8 heures et 15 minutes : 8:15

Ensuite il suffit d’effectuer votre calcul en utilisant la formule : 

= heures x nombre / “1:00”           Voir l’image 

ransformer un nombre en Heures : Minutes : Secondes

Il Faut de diviser le nombre par 86400 et mettre ensuite la cellule contenant le résultat au format de nombre personnalisé : HH:MM:SS

Passer d'heure Excel en heure centième

Passer d’heure Excel en heure centième : HeureExcel*24 .

Exemple : A1=1:30. A1*24 donne 1,50 (ne pas oublier de mettre la cellule contenant la formule dans un format numérique et non date).

Détecter si une date se situe dans une année  bissextile.

La formule suivante :

=SI(MOIS(DATE(ANNEE(A1);2;29))=2;VRAI;FAUX) 

renvoie VRAI si la date en A1 est bissextile et FAUX dans le cas contraire.

Rechercher le dernier jour d'un mois

Rechercher le dernier jour d’un mois.(30, 31, 28 ou 29) 

=JOUR(DATE(ANNEE(A1);MOIS(A1)+1;0)) 

A1 contient une date au format Excel évidemment. (jj/mm/aa)

Afficher le jour d'une date avec une majuscule pour la première lettre

Afficher le jour d’une date avec une majuscule pour la première lettre :

 

=STXT(MAJUSCULE(TEXTE(A1;”jjjj”));1;1)&STXT(TEXTE(A1;”jjjj”);2;10)

 

A1 contient une date au format excel

On obtient le même résultat avec : =NOMPROPRE(TEXTE(A1;”jjjj”)) 

 

A noter que “jjjj” peut être remplacer par “mmmm” (pour obtenir le mois) ou encore par “jjjj mm aaaa”….

Calculer et obtenir des heures négatives

Calculer et obtenir des heures négatives :

=(SI(B1>A1;B1A1;”-“&TEXTE(A1B1;”hh:mm”)))

 

Dans ce cas si A1=7:00 et B1=6:00, on renvoie bien -1:00

Calculer le nombre de dates apparaissant pour un mois donné avec la fonction =NB.SI()

Pour compter le nombre de dates relatives à un mois donné on utilise une formule spécifique décrite ci-dessous.

Exemple : Cette formule est construite pour compter le nombre de dates relatives au mois de janvier 2017 à partir d’une liste de dates saisies dans la plage de cellules A2:A7

En C2, on écrit “Janvier” (ou bien 1/1/17)

En C3 on écrit la formule suivante :

=NB.SI(A2:A7;”>”&DATE(ANNEE(C2);MOIS(C2);0))-NB.SI(A2:A7;”>”&DATE(ANNEE(C2);MOIS(C2)+1;0))

Le résultat de cet exemple donne le chifre 4

Insérer l'heure ou le jour..

Il faut utiliser la combinaison de 2 touches :

  • Insérer l’heure : CTRL : (Touche “Contrôle” + “double point” )
  • Insérer la date du jour : CTRL ; (Touche “Contrôle” + ” point virgule” )